We're ready for another round of ISO testing!

Hey ya’ll, thanks to @dogphilosopher 's heroic last minute efforts fighting with R2 we’ve got new Bluefin ISOs up!

We now ship the Flatpaks on the ISO itself, allowing for a full offline installation. This allowed us to remove a bunch of service units that were trying to install Flatpaks after your first boot, etc. This is why we only install the browser and a handful of apps, now we can ship what we want right on the installation media. Once you boot into it we’ll do a background flatpak update -y and then you’ll be good to go. The ISOs will respin regularly to keep them fresh.

This also means we can put Thunderbird on the dock, as has been intended:


Yafti’s main purpose was to do flatpak installation and since that need is gone I’ve removed yafti from the default Bluefin install. This is actually quite clean, it just boots right into the desktop ready to go.

However there’s something nice about a quick guided tour. Yafti will return, currently @abanna is reworking yafti considerably, and it’s going to come back much better, being more of a config app than a next-next-next app. In the meantime since we’re growing up we gotta leave the current implementation in the past.

This will take a bit to get to Bazzite as getting the flatpaks on the ISO is a gigantic pain in the ass, which is why we tried it with Bluefin first. They’ll be ready in time for F40.

You can test these by choosing them from the image picker and downloading the ISO.


Is it possible to have Flatpaks integrated to a personal Blue Build ISO as well?

Not sure but here’s the ISO generator you can use: GitHub - JasonN3/build-container-installer: Creates an ISO for installing a container image as an OS

I tried latest Bluefin-dx , no issues. Kinda weird without “yafti” but it is ok. No issues at all.

And my first step after boot is remove Thunderbird xD

I just tried the developer edition Framework ISO on a Framework 13 AMD and got the error:

../..grub-core/kern/fs.c:121:unknown filesystem.
../..grub-core/loaderi286/efi/linux.c:258: you need to load the kernel first

The error occurred whether trying to install directly or enter a test environment. The boot drive was made using Impression and it (and the laptop) does boot other ISOs. I verified the checksum of the Bluefin ISO and it was fine. I know very little about how Linux works under the hood, so I’m not sure what to make of the error.

Which exact ISO is it? (Filename is fine)

It was bluefin-dx-gts.iso