Trying to update the system - error

Trying to update my steam deck gnome installation and getting this error in the console. What am I doing wrong? I’m new to the system and to the Fedora linux. I tried googling the thing and haven’t found anything useful.

── 20:32:56 - System update ────────────────────────────────────────────────────
Pulling manifest: ostree-image-signed:docker://
Checking out tree 8b91445... done
Enabled rpm-md repositories: fedora-cisco-openh264 updates fedora rpmfusion-free-updates-testing rpmfusion-free-updates rpmfusion-free rpmfusion-nonfree-updates-testing rpmfusion-nonfree-updates rpmfusion-nonfree hardware_razer rpmfusion-nonfree-steam google-chrome rpmfusion-nonfree-nvidia-driver updates-archive
Updating metadata for ''... done
error: Updating rpm-md repo '': cannot update repo '': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried; Last error: Status code: 404 for (IP:
System update failed: 
   0: Command failed: /usr/bin/rpm-ostree upgrade
   1: /usr/bin/rpm-ostree failed: exit status: 1