Setting up the Ptyxis Terminal

Bluefin, Aurora, and Bazzite use the Ptyxis terminal, a container focused terminal designed to make working with containers seamless. Hitting Ctrl-Alt-t will launch a host terminal. We recommend right clicking on the tab and pinning the host, so that you have it handy.

And then set a container in the profile settings, ubuntu or whatever container you want:

Once you get used to a container-native workflow you’ll end up naturally in a container.

You can pin then both to keep them handy, Alt-0 and Alt-1 switch back and forth between the host and the container.:

All of your distroboxes are available in Ptyxis’s tab so you can quickly create new ones as you need them:


Adjusting Transparency

Ptyxis doesn’t expose adjusting the transparency in the settings, there’s a ujust convenience command you can use to modify it:

ujust ptyxis-transparency opacity="0.95"

Adjust the level of transparency you want between 0 and 1 to get the desired effect.


@j0rge I am following this guide, but I am getting some small glitches.

  • If I open a Tab in a container from Prompt (say, bluefin-cli), I get a “blank” prompt, like some rc file has not been sourced, like this:


  • If I check the profile option to use a login shell, things improve a bit:

    :package:[valmar@bluefin ~]$

However, the prompt and the shell have no colors (this does not show in the text above, unfortunately), and are strictly black and white!

I am not reporting this to complain, of course, but to see if we can improve the experience together. I actually love Bluefin, thanks for the great work!

1 Like

Yeah we’re almost done with the box so that we can add some nicer colors, etc. I always set mine to login shell and the prompt is there, maybe we should set that by default?

1 Like

Thank you for the quick answer! Yes definitely! I would do that. My guess is that most of the time people will want to open a login console. But where are the colors set? I don’t see anything in .bashrc or .bashprofile. When I enter the bluefin container using “distrobox enter bluefin”, the prompt color is there

1 Like

Someone smarter than me will have to take a look :smiley:

But hey, semi related since you brought up colors. I’m wondering (for bluefin-cli specifically) if we should ship the color configs and whatnot in the container itself and just not touch the user’s home directory at all?

Like if we shipped eza as our ls the people can just snag the container and it would have all that stuff but we wouldn’t mess with their dotfiles at all. What do you think?

cc @m2Giles

Thank you! The strange thing is that if I start the container with distrobox enter, the prompt is colored! What could be the difference between this and what Prompt does?

Distrobox enter if there is no command will default to your login shell.

When using prompts menu it will instead default to whatever is in your prompt profile. Which is a non-login shell. You can change this option by editing your profiles.

I’m adding a change to have interactive shells source /etc/profile which will make the menu work option work out of the box.

Additionally a login shell is how we trigger sudo setup and having your brew moved into the correct location.

And yes, I want to put those creature comforts like colors in the container. I was also playing with starship in the container but don’t like the default container config.


@m2Giles let me know if I can help, at the very least with testing

I have installed Bluefin using this ISO

Is it meant to have the Ptyxis terminal by default or do I need to install it? I have distrobox set up but don’t see the menu option to switch containers.

It’s not in the 38 releases (39 only). You can rebase to 39 if you want to mess with it or you can use the flatpak installation on 38 if you prefer to do it that way.

A short how-to on adding Atuin (and maybe even the other bluefin-cli stuff) to Ptyxis would be cool. I am lost at part tbh.

1 Like

Does anyone know if there’s a way to configure Ptyxis to launch in fullscreen? I like to dedicate a workspace to my terminal, so I have it launch on boot. Is there an argument to force fullscreen?