Bluefin/Aurora is not working out for me. Why?

My honeymoon period is over and I’m having a lot of issues (latest Aurora 39 build). I began to embrace the “don’t customize everything” that comes with Linux. However, is it just me or a bad build?

I had a repo I didn’t know what to do with, no documentation except some high level things. I decided to create a Code directory under Home using the Bluefin-CLI (distrobox not terminal) and pull down the repo. I spun up DevPod to create a devcontainer. For some reason after it tried to connect the devcontainer SSH wasn’t in my path so I received a weird error when it tried to open it in VS Code.

Also the dev server wasn’t installed on the repo, whatever. Restarted Ptyxis, no go, then I restarted a few more times and for some reason I was in my preferred shell in the CLI and it all connected fine. I had SSH and UJust and and code (everything seemed to be gone yet $PATH showed no differences).

Got that running, then I tried to install Starship via Brew bundle and it had an error in the end that a directory wasn’t accessible during a self test with fish (sorry didn’t copy it I am assuming it wasn’t because I haven’t touched fish in the CLI and it didn’t “exist”? Once in awhile still getting odd SSH and $PATH errors suddenly stopping working but restarting works.

I noticed bazzite had nix installed which I need and thought I’d just install it “correctly” but looking at how other items are installed as a container and how some people even install fonts (?!) that way, I decided to just copy how bazzite did it. Seems to maybe sort of work?

ujust also has a bunch of commands that don’t make sense with KDE and the documentation is confusing, like the ISO releases are under assets but the gnome flavor. And there’s ujust commands that don’t make sense under KDE (like gnome-extensions).

I have just the Aurora-DX installed yet sometimes both Chrome and Firefox will load without images and stylesheets correctly, a refresh will take care of it but haven’t figured out what might be causing that.

Even though bazzite is for training I’d almost rather deal with the deterministic issue by using ZFS and taking ZFS snapshots. Or use chezmois and a git repo with package lists and dot files to “rebuild” nightly.

This feels more like a server when you move out of dev playground phase to needing to share things.

I really appreciate this and I love it and know it is a work in progress but it feels like there’s a workflow needed to explain how to do things after a fresh install, and what to do and what not to do. Even before I started saying “screw it” and installing the nix installler, I still had random issues with the bluefin-cli.

The nVidia installer gave me a bunch of grief so I reformatted and installed from scratch.

I received a highend Dell and due to internet issues I can’t depend on my MacOS + SSH into a dev box and was hoping this would suffice. I know this isn’t helpful without exact bug errors, but it “feels” like there’s a certain setup I need to go through after I boot from a fresh install to get things functioning correctly.

Any advice? Working inside a VM/distrobox inside a docker container like bluefin-cli seems like overkill. If I had a language or regular flow of work I used maybe this would be easier but I receive often poorly built repos in languages I haven’t used in years.

Or just go back to the gnome build?

This image is a few days old and most/all of the attention has been on F40 since most people are using it for F40 and Plasma6. Many of the problems you are running into appear to be due to no one really using this image. I had forgotten we were even making 39 for this!

Yeah we bundle a bunch of software, we don’t really have the people power to redocument things, so in this case for example I would point you to the devpod documentation.

You shouldn’t have to do this since we ship starship ootb. I’m also pretty sure we have gaping holes in our fish coverage all over the project. We mostly tread on the default path, so if you’re using an alternative shell we need those reported (and also PRs/fixes accepted!)

We haven’t recommended nix for a long time, it’s an unsupported configuration, mostly due integration issues and SELinux issues.

Yeah we’ve been trying to organize and document the just commands but there’s just not enough people adding to the documentation. They’re set up as wikis. Hopefully more people will dive in!

Yeah for most people I recommend just installing brew for CLI and using flatpaks. Sounds like bluefin-cli’s workflow isn’t for you.

My recommendation would be to run on F40 and start with a stock configuration and work your way out from there as you become more comfortable. Cheers and thanks for the feedback!

Cool well you know maybe I’m not understanding distropacks and got a bad build. When I got F40 on KDE all the icons in the terminal were screwed up. Maybe a dev machine with nix would be best I don’t care about system package management but project level. I’m a bit confused on distropacks though if I install one next to bluefin-cli will it work in isolation?

Also what’s the best way to delete everything and move to 40 without a format and reboot? Like I don’t care about my settings, etc. I want to format without going through a format just keep the rpm-ostree containers basically. Is that possible?

Might try nixos as a vm and just ssh into that or create dev containers.


Creating a new user is the cleanest way to do that currently.

Cool I’ll try that out! I’d love to contribute back just didn’t know if it was me or what. I’ve had to format twice now due to various issues with the nvidia drivers, and there’s an upstream issue where a corrupted commit in the ostree is basically impossible to resolve. Due to construction near me my fiber got cut so reformatting is a lengthy process, so there’s been some outside frustration :slight_smile: