KDE Partition Manager Crashing When Removing Mount Point

I have been attempting to follow the auto-mount drive guide. Research didn’t find anything either.

So far, I have changed the mount point to a point within /mnt. But I did not know I had to reformat the drive since it is in NTFS(these drives are from Windows). I went back to the documentation and removed the mount point before I formatted the drive to EXT4, but the KDE Partition manager just crashed.

All the data on the drive seems to be fine since I haven’t formatted anything, the app just doesn’t seem to work.

I’ll make a post on KDE, but I really have no idea what to do. Would it be safe to complete this operation in the terminal?

Any help would be greatly appreciated; besides this, I’ve really enjoyed Bazzite.

It should be safe to format drives on the terminal, but if you’re more comfortable doing it from a graphical interface and KDE Partition just won’t work, you can try out GParted Live, other Linux rescue media, or just about any Linux installation media that have a live environment. From there you can open their partition manager, format your NTFS drive, and make it ext4. Be sure to backup your data before! After the operation is done you can just exit the boot media, unplug the USB drive and then boot back into Bazzite.

Having a USB stick containing Linux rescue utilities is always good!

I downloaded gparted-live-1.6.0-3-i686.iso and put it on my inventory USB drive, and whenever I would try to use the boot menu(f12), it would start to repair the d: drive.

So still no dice, do I need to use a different version of Gparted, like the amd64.iso?

Wouldn’t be better if you try your mounts under /var/mnt instead?
Mounting under /mnt or /media causes undesirable effects, in my experience.

i should’ve specified but they mount locations are in bazzite-nvidia_fedora/var/mnt and when I go to remove the mount point in KDE partition manager it just crashes.

I’m trying to follow the directions but I’m not getting anywhere

Have you tried with sudo umount /dev/sda1, or whatever your drive is?

My advice is try to format, partition, mount and unmount the drive with terminal commands. GUI apps tend to be fragile and don’t tell you the underlying issues.

I haven’t tried to format the drive or anything since the guide said

" Warning : Do not set up auto-mount, unmount then format a drive! It can confuse the software you are configuring drives with. Instead, remove the auto-mount first before formatting the drive ."

And I did set up auto mounting, before formatting. Since I can’t remove the mount point I can’t turn off the auto mount

I see. Can you see an automount line inside /etc/fstab?

What you could do is comment the automount line in fstab, save, and then restart. That will skip the automount of your portable drives.

I looked inside fstab(I really don’t know what this means) however I noticed that the information related to the drives in question seemed off compared to the info for my nvme drive.

UUID=A0CE8ACFCE8A9D62 /var/mnt/2tbhdd ntfs noatime,users 0 0
UUID=1A7CB1307CB10791 /var/mnt/1tbsata ntfs noatime,users 0 0

The HDD and SATA are the drives in question, the sets of 2 0s and noatime users caught my attention

These two drives will be mounted at boot. You may want to comment those two lines to prevent them to mount, if that is the effect you are looking for. Use # at the start of each of the lines showing the drives.

To edit /etc/fstab from the terminal:

sudo nano /etc/fstab

Make the modifications if you are comfortable with it, and save the changes with Ctrl+X and enter. Then, restart.

I will say this with the best intention: I have been using Linux since the late 1990s, when RedHat was given for free inside magazines. Quite a little while. And then came immutable operating systems such as Fedora Silverblue, and from last year a flood of its derivatives, such a Bluefin and Bazzite.

Silverblue and derivatives is the hardest Linux I ever faced. Very tough to configure and make applications work in a compartmentalized isolated way. Challenging but never boring. Everyday you learn a new way of doing development or configuring things. It is just a steep curve of learning, like suddenly the Linux you knew is below 101 level, and have to learn advanced Linux stuff to drive it.

I would say Silverblue, Bluefin, Bazzite, Aurora, and all the atomic OSes definitely represent a paradigm shift.

I appreciate all your help today. I’m gonna educate myself on fdisk and give it another wack tomorrow, probably. All the important stuff on my PC works. My Steam library is just a bit small atm.

Basically, what happened was that since we usually play the Windows versions of games through Proton, I figured that I would not have to reformat my game drives, so I’d just have to set up automounting, which was easy. This was before I knew about the different file formats lmao