Automount not providing exec despite fstab flag and user perms?

I finally (partially) figured out an issue that has been driving my absolutely insane and causing me to leave cryptic help requests all over the internet (including here).

For reasons unknown to me this fstab entry auto-mounts at boot (as expected) but without providing exec ability despite having the exec option set and individual files having the exec permission.

UUID=e2506416-54b9-41ff-90da-b079114b071b /var/mnt/games ext4 defaults,errors=remount-ro,nofail,rw,exec,noatime,users 0 0

This also extends to unmount and mounting the partition from the CLI after boot. Here’s the kicker though: If I unmount and then re-mount it using KDE Partition Manager after boot, however, I get exec ability and suddenly everything works. Why am I not getting exec from automount or CLI? Why does it work with KDE partition manager? How can I automate this so I’m not manually toggling it every time I reboot? For reference I’m running UBlue Bazzite KDE 40 without a root account activated during the fedora install and I followed the directions here in order to set up the drive. This is a fresh install + ujust update.

To be very explicit regarding the chain of events is:

  • log in after initial boot
  • try to run an executable from that drive – get permission denied (rwx are definitely set)
  • umount games
  • mount games
  • try to run an executable from that drive and still get permission denied
  • go into kde partition manager → right click unmount
  • kde partition manager → right click mount
  • try to run an executable from that drive and it works(!)

Any ideas why automount is failing me?

Try to put ‘rw, exec’ at the end, this makes sure that those options are the last ones set.

1 Like

We edited the guide so good catch. I really wish automounting secondary drives on Linux still didn’t require all of this.

Try to put ‘rw, exec’ at the end, this makes sure that those options are the last ones set.

This solved it. Thanks so much!

You have no idea how much pain this has caused me because it presented so oddly–it took me a long time to figure out I wasn’t getting exec on this drive as I only interacted with it through steam and many of the games were essentially just acting as data running through compat layers executed elsewhere.

Just adding a follow up for anyone who followed the latest guide and is still having issues. If you’re setting your drive with KDE partition manager, check fstab afterwards to make sure rw,exec has been written last.

For me, partition manager always writes the options check box settings last (i.e. atime and users) . It didn’t seem to matter what order I set it , eg ticking Options first, then clicking More and adding the other options or the other way round. Manually editing the order in fstab fixed it for me though.

Same here - I had to manually edit /etc/fstab file which was pretty easy to do, although a little scary for linux newbs like me