I can't install Bazzite

I have 2 SSDs, one with Windows and i’m slowly migrating to Linux. On the 2nd SSD there were several distros, lately a Fedora40 which died from the latest Mesa update so i thought i try Bazzite but for the life of me this thing does not want to be installed. I’m slightly frustrated, forgive my manners.
During the installation i choose to format /, /boot/efi and leave /home as is but it always quits with an error message stating it cannot create grub. I read previously that it could be an issue because i had Fedora so i formatted the boot partition from windows, same issue. When i choose to ignore the issue it simply quits with a fatal error.
It should be simple. It should be ‘next-next-finish’. What am i doing wrong?

Hi! I believe the recommended manual partition layout is like this (from here):

Manual Partitioning Scheme:

mount point: /boot/efi  
format:      EFI system partition
size:        300MB  
(optional: use existing system EFI partition)

mount point: /boot
format:      ext4
size:        1GB

mount point:
format: btrfs
size: [max]

mount point: /
format:      btrfs (subvolume)

mount point: /var
format:      btrfs (subvolume)

mount point: /var/home
format:      btrfs (subvolume)

A home subvolume can be mounted at /var/home can also be added to the btrfs volume during the installation, and after installation you can mount additional drives at /var/mnt/drive-label. I’m not sure if using /home and missing explicit creation of /boot will cause GRUB installation failure, but maybe you can try following the specified layout or use automatic partitioning instead?

As i mentioned, i was frustrated. I followed the manual partitioning scheme and it worked instantly. Thank you!

P.s.: don’t do this at 2am, not worth it

Happy to hear it worked! Enjoy Bazzite! :partying_face:

I too have gone through many frustrating consequences of 2 AM decisions…