Customise grub flags

hi all
i would like the following to be enabled in bluefin like i do in my mutable systems:

GRUB_CMDLINE_LINUX="rhgb quiet elevator=mq-deadline rw mitigations=off"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash zswap.enabled=1 zswap.compressor=lz4 zswap.max_pool_percent=10 zswap.zpool=zsmalloc"

how can i get it to ostree this or make it stay / work in bluefin?
i rebuild my grub but when i enter the grub entry at boot, i dont see my custom config?

Much appreciated.

you would want to look into rpm-ostree kargs --help :grinning:
rpm-ostree kargs will show the current kernel args for grub, and you can pass arguments to it to modify the kernel argument line for grub.

you will not be able to split it up between DEFAULT and non default though.
the arguments listed are the ones that will be used.

1 Like

Hello and thankyou for the insight.

Bluefin/Silverblue is definately a different beast compared to nixos!

With your help Ive sorted it out and it works, well i hope so.


┌(tolga@bluefin) ➤ ~  
└➤  rpm-ostree kargs
rhgb quiet root=UUID=81ce8f42-fbc6-40ee-912d-7b0fe9ac341e rootflags=subvol=root rw ostree=/ostree/boot.1/default/b7cffa6760fe30f62cff9b5afdeb39426704395cad384f848f3293fd028a1ba1/0 initcall_blacklist=simpledrm_platform_driver_init


sudo rpm-ostree kargs --append=“rhgb quiet elevator=mq-deadline rw mitigations=off”

sudo rpm-ostree kargs --append=“quiet splash zswap.enabled=1 zswap.compressor=lz4 zswap.max_pool_percent=10 zswap.zpool=zsmalloc”


┌(tolga@bluefin) ➤ ~  
└➤  rpm-ostree kargs
rhgb quiet root=UUID=81ce8f42-fbc6-40ee-912d-7b0fe9ac341e rootflags=subvol=root rw ostree=/ostree/boot.0/default/b7cffa6760fe30f62cff9b5afdeb39426704395cad384f848f3293fd028a1ba1/0 initcall_blacklist=simpledrm_platform_driver_init rhgb quiet elevator=mq-deadline rw mitigations=off quiet splash zswap.enabled=1 zswap.compressor=lz4 zswap.max_pool_percent=10 zswap.zpool=zsmalloc

Faster boot and alot more responisive. Also added CAKE qdisc with a bandwidth limit of 1 Gbit/s to both wlo1 and wlp3s0 interfaces

Thanks for these suggestions @tolga_erok but there is something unusual about the quotation marks used in your code snippets (for me at least).

Copy/paste into my terminal gives me this:

Instead if this:

Which created a bunch of this weirdness in my kargs

Screenshot from 2024-06-09 08-02-32

In the end I used this to correct:

sudo rpm-ostree kargs --editor

While I’m here - what did you use to get that awesome looking top bar in your screenshot?