Cant be serious, right? Not happy

I’m experiencing a curious behavior on my Silverblue/Bluefin system, and I’d love to get your input on whether I’m missing something or if this is a known quirk.

When I double-click on a file in the Files app, I’m not able to edit it directly. Additionally, when I try to access files using scripts, I’m finding that the default path is /var/home/username/xxx instead of the expected /home/username/xxx.

Am I just not understanding the file system layout, or is this a deliberate design choice in Silverblue/Bluefin? Is there a way to access the /home directory directly, or is there a workaround for scripts that rely on the /home path?

In Fedora Atomic Desktops, most directories are read-only.
A notable exception is the /etc and the /var directory.

  • /home is a symlink to /var/home

Scripts relying on /home should work the exact same way as on a traditional distribution.
Run this and see the folder testdirectory created in your home:

#!/bin/bash
mkdir /home/$USER/testdirectory

As for double-clicking a file in Nautilus, I have no idea what you’re talking about. Maybe you don’t have the correct associations for files, but that should prompt you with the open with dialog.

1 Like

I sincerely apologize for the typo :flushed:.

What I meant is that the title bar in files/nautilus cannot be edited, preventing me from manually entering the location by hand.

You’re probably on GNOME 45 (Fedora 39), you can edit the location manually using the key combination <CTRL+L>.

On GNOME 46 (Fedora 40), nautilus’ location bar gained the ability to be edited just be clicking it.

If I’m right and if you’d like to upgrade, see the documentation on how to rebase. If the link doesn’t take you to the exact part, it’s under System Updates → Upgrades and Throttle Settings.

Indeed, what you are asking is available in Gnome 46 (Fedora 40)

By default, Bluefin and Aurora are on the :gts version (previous still supported major version, which currently is based on Fedora 39 - Gnome 45).

If you want to switch to :latest (which is based on Fedora 40 - Gnome 46 currently), as @lorduskordus said, you can follow the instruction there
TL;DR: rpm-ostree rebase ostree-image-signed:docker://ghcr.io/ublue-os/bluefin:latest

Before going so far as to rebase, you might want to explore Dconf Editor. Enabling “always-use-location-entry” allows for the behavior you expect. I’m on GNOME 46, but I’m pretty sure this is also on GNOME 45.

If you’re happy with GTS, and just need some behavior tweaked, you shouldn’t need to rebase. And well, by default you can already do that in Nautilus by double clicking instead of single clicking :smile:

2 Likes

Great suggestion

I didn’t know it was being a dconf flag

Will try this out. What screen capture apps u using? Spectacle?
Did u use brew unstall ?

No, just Flameshot from Flathub. After installing you have to run flatpak permission-set screenshot screenshot org.flameshot.Flameshot yes in the terminal to give it screenshot permissions, and then create a shortcut for the flatpak run --command=flameshot -u org.flameshot.Flameshot gui command in GNOME Settings.

Brew is not recommended for installing GUI apps, it’s more for CLI/terminal utilities. For GUI you’re highly recommended to prioritize installing things via Flatpak, then via Distrobox, then layers (rpm-ostree install).

3 Likes

Sorry, where do you create the shortcut?

Unfortunately, the shortcuts dosnt seem to launch it, but it works now, painfully by activating it via the pinned icon

This works for me:

If flameshot isn’t installed at the user level, remove -u from the shortcut command.

2 Likes

nope, mimicked the same as yours, dosnt launch

please ignore, it worked after removing the -u

flatpak run --command=flameshot org.flameshot.Flameshot gui

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.