Trezor and Surfshark. Cant use them on Bluefin

I was loving bluefin and using it for some weeks… but them I gave up trying to make these two softwares workl (Surfshark and Trezor). I tried everything I could to make them work, and nothing.
I though it might be something related to the immutable nature of the distro so I tried install normal Fedora (that I am also not very familiar with, since Im a ubuntu/debian derived distros user) and it was so easy to make them work… So I assume I don´t have the full expertise to use a immutable distro such as Bluefin, unfortunately. :frowning:

Wireshark

The app is only available as a .deb (Debian and derivatives), it could be repackaged to the .rpm format used by Fedora with alien. Then you’d install it as an overlay using rpm-ostree install <package.rpm>.

Or better yet, you could just manually setup a WireGuard or OpenVPN connection, no app needed. See this for OpenVPN. (Once you get to the ‘Configure the Network Manager’ part, skip to step 5)

Trezor

  1. Install trezor-common using rpm-ostree install trezor-common.
  2. Reboot to apply the changes from the command above.
  3. Download and run the Trezor Suite AppImage. (Link from their website.)

No guarantees, I use neither Wireshark or Trezor. This is what I’d try if I was in your position. I did setup both WireGuard and OpenVPN manually from some provider before though, that should definitely work. Alternatively, you could subscribe to another VPN provider which uses a ‘proper’, universal app format, Flatpak, such as ProtonVPN.

I can’t seem to find where in surfshark the wireguard config is but if you can find it you should be able to just import that into network manager.

You can download the wireguard/openvpn config from the surfshark admin page if you are logged in. This way I have imported my suftshark vpn configs in bluefin. Can confirm it works ( both wireguard and openvpn configs )

1 Like

hi @jasper_van_der_marel,
can I choose one port randomly or there are rules about choosing one over another?
My choices are 443, 80, 53, 123, 1194, 65142.

I would fill it like…?
Connection Name: New York
Interface Name: Windscribe
Private key: the one I get
Listen port: the one I choose

What about fwmark, MTU and peers?
I’m using Windscribe and I don’t have a static ip.

Also can you use wireguard vpn and tailscale?

thanks a lot!

Hi,

I am using surfshark and its wireshark configuration and it looks like this.

1 Like

great! thanks for sharing :+1:

If it helps anyone else, I am successfully using Trezor on Aurora without any rpm installs.

  1. Install the Trezor Suite appimage.
  2. Download the udev rules from this file and copy to /etc/udev/rules.d/51-trezor.rules. (In case that link changes over time, your can find the full udev rules explanation from Trezor here: https://trezor.io/learn/a/udev-rules.)

That’s it, everything should be working fine.

If you want to use Metamask, do that from Chromium/Chrome as it supports webusb and you don’t need Trezor Bridge. I haven’t tried it, but it’s also possible to install Trezor Bridge with brew.