Steam Library Across Multiple Drives, Best Practices?

Hey what’s up ya’ll

I prefer to have my games installed on a drive separate from my system drive, for the most part. So, I was wondering if anyone has any info about setting up the Steam library across multiple drives. Between the Auto drive mounting procedure and Bazzite being atomic I was curious if anyone had any tips for setting something like that up safely and reliably.

To clarify, I don’t mean using the same “Steamlibrary” folder across several drives; I mean having my games downloaded across multiple drives.

You mean having multiple SteamLibrary folders, right?

I did this on my PC. It’s not hard, you just mount the drive with KDE Partition Manager or Gparted (which, really, is just editing your /etc/fstab file), and then tell Steam to use that folder as an additional SteamLibrary folder (you’ll need some extra steps if you use Flatpak Steam, but Bazzite comes with native Steam so that shouldn’t be an issue).

I recommend using btrfs since for some reason btrfs is easier to be read by Windows for some reason.

Steam supports this natively, but I ran into some bugs if there’s not at least one game installed in the default location. Steam settings → Storage → Drive drop-down at the top → Add Drive. There’s an option to set default drive under the ellipses menu.

I’ve gotten everything properly mounted, but when I go to add the drive in Steam, it doesn’t do anything after I open the file menu and click add folder in a subfolder in a mount location.

EX: mnt/mount name/steam/steam library, I highlighted the steam folder and selected to create a new steam library; it created a subfolder called steam apps, but steam doesn’t like it.
I opened the mount location folder as an administrator and gave the steam folder full permission to read and modify, so I don’t know what’s up.

Yeah, same issue for me!

1 Like


I have the same issue.
I followed the guide here : Auto-Mounting Secondary Drives

I also tried to mount the drive in var/mnt/games, /var/home/myfolder/games/
With no success yet. :cry:

It worked after many tests.

It seems that the workaround was to unmount the disk, then do “chown $USER:$USER /var/mnt/games” on the destination folder, and remount the disk.

(not 100% sure if that was the only thing that solved it, because we did a bunch of other manipulations before)

Is $USER a placeholder name where I put my user name, or does it mean the user of a given file?

I’m new to linux and I’d just like to understand a little bit more about a command before I run it, thanks!

It’s the “current” user.

I’ve had this issue too, seems like Bazzite (or SELinux most likely) have some special requirements to attach disks.

I also followed the guide suggested by Etocsi (Auto-Mounting Secondary Drives) created a folder on /mnt, technically I understand that /mount is just a link to “var/mnt”, so in the end it should be the same, but to save a click I always click “mnt”, my folder is for example /mnt/games4tb, to be exact, and to create a folder in mnt we need admin rights, so the folder will only be accessible by the admin/root.
Thats where the “chown $USER:$USER” comes if, after execution we should be able to right click the folder → properties → Permissions and see your user in the Ownership.

Selected that folder as the mount point and add the BTRFS Filesystem arguments (as my drive is BTRFS).

Then on Steam go to Setting → Storage → Add Drive → here it should either show the drive directly or we can click let me choose another location → Add → go to the mount point (mnt//createOrSelectYourDesiredSteamLibraryFolder) and that should be it, should be able to install and game with Steam on other drives.

There is one small caveat for games that has EasyAntiCheat, and I think it is not possible to play them on other drives.
For example Elden Ring and The Finals, I was able to install them all fine on the
other internal drive in mnt, but when I open the game the EAC window pops up, load and fail with “unable to find process path” if my memory does not fail me.

After various tests what solved it was moving the games to the home drive where steam default library is, after that the games boot up with no issue at all.