Rocm amd drivers

I have been stuck using windows to carry out my AI related tasks and general use as I am not able to be successful at installing the provided rocm amd driver installer provided on amd site on bazzite . The iso version I used was Nvidia but I sold the Nvidia gpu and threw In a rx 6800 and for ollama to make use of the GPU at all its required to have to successfully installed the rocm drivers and binaries. I really need help this area is not my cup of tea pls and much appreciated.

The rocm packages are included out of the box!

Help me out here . I installed on this PC the Nvidia iso . What do I have to do to setup rocm . When I run ollama there terminal tells me it does not detect rocm

Trying to avoid wiping but this had a 2060 originally so I went with the Nvidia iso

Now I can’t seem to get ROCM to be detected by ollama runtime

Paste in an rpm-ostree status for me

Sorry for wait everything is slow loading in rn

First you need to follow these instructions to get future updates: Important announcement regarding system updates [Action needed]

After you’ve rebooted into an updated image, then run this command to rebase onto a non-nvidia image, which has the rocm files:

rpm-ostree rebase ostree-image-signed:docker://bazzite-asus:latest

Wait for the transaction to finish and then try again (that might take a while depending on what it’s doing)

Btw thank you for taking the time out of your bz day to assist me . The only reason I don’t want to wipe this setup as I do see it logically as the simple solution here but the setup I have rn is alot of work and it setup to easily publish models to ollama like it’s such a pain but your assistance means to me of much appreciation. . I’m not sure why this is still erroring out I did a reboot and this is try 2

Forgot to add

This is also the first curl command not the switching of distro off Nvidia this is to get the new and correct repo I believe or what ever fix from before due to release error of an update if I recall can’t remember it all correctly. But I came by it and.had to do it on my legion which was successful

If that second curl command is the one that just switches the distro types, is it really required of me to run the first curl command? I mean the fix would be technically already implemented from being included in the current available release ?

It’s wanting me to do some extra stuff not accounted for like a optional fedora release

This after it finally ran and then I rebooted to this here

Not tryna annoy . I use debian systems I only use bazzite because after my self comparing benches and results for AI your platform runs local llms better than debian ARCH F#$KN LINUX steam os cachy os Kali (that was pain on Kali) but bazzite just runs these models so cleanly and noticably faster . Help me out mate pls

I resolved the issue by rebasing to gnome this also got me off Nvidia and now lact shows installable in portal

If recommended some changes to the instructions on page none of the would work . It always error out. But just rebasing with the curl link to stable gnome resolved all issues in one go

Only thing I haven’t solved is purging Nvidia . Idk what else Todo outside that cause currently ollama still falls back to cpu saying it didn’t find rocm driverd

So done with this platform going back to arch where rocm actually works