New here and would like to say hello 🥳

Hi! Thought I’d introduce myself around here, I hope fluff posts are allowed :blush: I’m Mel and I’ve recently switched to Bluefin, I used to use EndeavourOS for about a year and a half and then Fedora Workstation for less than a month. My experience has been very nice so far, though initially it took me a looot of effort and luck to get things right. My first Bluefin install caused a puzzling issue with suspend, and the issue persisted even across reinstalls. Eventually I fixed it in Fedora Workstation 39 and found out something was off with my wireless mouse. The weekend after I gave Bluefin another try, suspend isn’t problematic and everything is fine… so here I am today, enjoying my very low maintenance system!

I’d tried Silverblue in the past briefly but it was just not for me, as I needed to layer a lot of packages, which (I know) won’t do me any good in the future. Right now I only layer packages for my fingerprint drivers (not supported by fprintd which has to be removed), intel-gpu-tools, tlp & tlp-rdw, throttled (which needs thermald removed), zcfan, and butter. Easy peasy! The only thing I’m looking to do is enable Secure Boot with lockdown LSM disabled for throttled, but this is a Fedora problem and not Bluefin.

So yeah I also just wanted to drop by and say thanks a bunch for the dev team, contributors and everyone who’s propping Bluefin up! I owe you ladies and gents and awesome people a big one for making my system hassle-free!

…also, one question: dinos aren’t shuffling for me, I only see Dolly if I run fastfetch from my host terminal (bluefin-cli takes my own .config files). Dolly is lovely, but I’d love to see the other dinos too every now and then. I did see this commit - does the fact that I’m using fish instead of bash matter?

Again, thanks a lot for working on this project! Wish everyone a wonderful morning/day/night! :full_moon_with_face:

1 Like

I’m guessing this is the issue. I just got a bunch of new dino artwork and the intent is for them to shuffle so you have a virtual zoo. :smile: We’re slowly getting parity with fish and zsh, but we need more people jumping in and helping out, so if you have more fish friends feel free to send them our way!

Thanks for the feedback!

Running fastfetch in a bash session (or changing back to bash from fish) doesn’t seem to trigger the shuffle, nor does specifying bash in I’ll play around a bit and see if I can get this to work somehow. Unfortunately I’m the only fish person that I know - pretty much everyone around me runs Win or macOS. :sweat_smile:

Hi again, I somewhat got it to work in fish as functions. Not sure where to drop this so I’ll just post here!

Without $BLUEFIN_FETCH_LOGO, aliased to dinofetch to avoid conflicts with existing fastfetch alias (~/.config/fish/functions/

function dinofetch --wraps='/usr/bin/fastfetch --logo (find /usr/share/ublue-os/bluefin-logos/symbols/* | shuf -n 1) -c /usr/share/ublue-os/ublue-os.jsonc' --description 'Randomize fetch dinos on fish shell'
  /usr/bin/fastfetch --logo (find /usr/share/ublue-os/bluefin-logos/symbols/* | shuf -n 1) -c /usr/share/ublue-os/ublue-os.jsonc

With $BLUEFIN_FETCH_LOGO, aliased to dinofetchv2 (~/.config/fish/functions/dinofetchv2)

function dinofetchv2 --wraps='set BLUEFIN_FETCH_LOGO (find /usr/share/ublue-os/bluefin-logos/symbols/* | shuf -n 1) && /usr/bin/fastfetch --logo $BLUEFIN_FETCH_LOGO -c /usr/share/ublue-os/ublue-os.jsonc' --description 'Randomize fetch dinos on fish shell v2'
  set BLUEFIN_FETCH_LOGO (find /usr/share/ublue-os/bluefin-logos/symbols/* | shuf -n 1) && /usr/bin/fastfetch --logo $BLUEFIN_FETCH_LOGO -c /usr/share/ublue-os/ublue-os.jsonc

Placing it on my user .config for now as I have no idea how to properly integrate it to /etc/ LOL. Hope this is of help! Looking forward to see more dinos around. :sauropod: