Issues with PC shutting down

Hi

Since yesterday, I’ve been having issues shutting down my PC. When I attempt to shut down from the application launcher, the taskbar disappears, my windows remain open, and my desktop background disappears, but I can still alt-tab between windows?

However, my PC will restart and go into sleep mode just fine.

I really don’t know what’s wrong; the only thing I can think of is that I made some updates in the Discover software center. I then updated my system and rebooted but the issue persists.

Any advice would be appreciated, thanks guys

Specs
CPU: i7 6700k
GPU: RTX 2060s
KDE X11

Hello,

you are not alone, I got the same issue.
Rebooting with $ shutdown -r 0 works fine, only the app launcher reboot / shutdown doesn’t work.

Linux 6.8.12-301.fsync.fc40.x86_64
X570 AORUS ELITE (-CF)
AMD Ryzen 7 5800X (16) @ 3,80 GHz
NVIDIA GeForce RTX 3080 Ti [Discr]
KDE Plasma 6.0.5
KWin (X11)
bash 5.2.26

Was just about to ask about this myself since I’ve had the problem for a few days now. I now have Ctrl+Shift+F3 to a terminal to reboot or shutdown when I tried to do it the “normal” way and end up with black screen.

I have auto-login set and use X11 since some of the tools I use do not work well under Wayland yet.

Some info if it helps the people who knows more. I’m pretty new to Linux.

                                            leslie@fedora
     %%%%%%====%%%%%%%%%%                
   %%%%%%%%    %%%%%%%%%%%%%%             󱋩  bazzite-nvidia:stable 
  %%%%%%%%%    %%%%%%%%%%%%%%%%           󰣛  Fedora Linux 40 (Kinoite) x86_64
  %%%%%%%%%    %%%%%%%%%%%%%%%###           Linux 6.8.12-301.fsync.fc40.x86_64
  %%%%%%%%%    %%%%%%%%%%%%%######        󰅐  2 hours, 34 mins
  ==                  =======######       󰔠  Spawned on May 29 2024
  ==                  =========#####     
  %%%%%%%%%    %%%%%%%####======#####     󰾰  B650M DS3H
  %%%%%%%%%    %%%%%#######=====#####     󰻠  AMD Ryzen 9 7950X3D (32) @ 5.76 GHz
  %%%%%%%%%    %%%#########=====#####     󰍛  NVIDIA GeForce RTX 4080 SUPER [Discrete]
  %%%%%%%%%    %%##########=====#####     󰍛  AMD Raphael @ 0.60 GHz [Integrated]
  %%%%%%%%%====###########=====######       12.53 GiB / 30.49 GiB (41%)
   %%%%%%%%====#########======######        677.05 GiB / 931.51 GiB (73%) - fuseblk
    %%%%%%%=====#####========######         3.28 TiB / 3.73 TiB (88%) - fuseblk
     %%%%###===============#######          1018.68 GiB / 1.82 TiB (55%) - fuseblk
      %#######==========#########           216.34 GiB / 929.93 GiB (23%) - btrfs [Read-only]
        #######################           󰍹  3440x1440 @ 100Hz
          ###################            
              ###########                 󰕮  KDE Plasma 6.0.5
                                            KWin (X11)
                                            bash 5.2.26
                                            ptyxis-agent
                                          󰏖  2915 (rpm), 86 (flatpak-system), 17 (flatpak-user)
State: idle
AutomaticUpdates: disabled
Deployments:
● ostree-image-signed:docker://ghcr.io/ublue-os/bazzite-nvidia:stable (index: 0)
                   Digest: sha256:51a8ccdc8741fd27715a4337906aeea8bd19c6e08113767da2049388e10efcb1
                  Version: 40.20240609.0 (2024-06-09T18:10:59Z)
               BaseCommit: c7875861cf0868a0e86516c857b527adcab532f1670a7069eaa1ff1c68865fc9
                   Commit: 9b9124118ee1ee859b6064abd382e25abc929dce8c4c91600abfece04d4be085
                           ├─ copr:copr.fedorainfracloud.org:matte-schwartz:sunshine (2024-06-02T08:36:27Z)
                           ├─ copr:copr.fedorainfracloud.org:rodoma92:kde-cdemu-manager (2024-04-20T12:39:00Z)
                           ├─ copr:copr.fedorainfracloud.org:rodoma92:rmlint (2024-05-10T10:16:28Z)
                           ├─ copr:copr.fedorainfracloud.org:rok:cdemu (2024-02-20T12:07:53Z)
                           ├─ fedora (2024-04-14T18:51:11Z)
                           ├─ rpmfusion-free (2024-04-20T12:11:51Z)
                           ├─ rpmfusion-free-updates (2024-06-07T11:49:49Z)
                           ├─ rpmfusion-free-updates-testing (2024-06-07T11:51:16Z)
                           ├─ updates (2024-06-10T01:23:37Z)
                           └─ updates-archive (2024-05-22T01:41:39Z)
                   Staged: no
                StateRoot: default
          LayeredPackages: cascadia-fonts-all dotnet-sdk-6.0 edk2-ovmf freerdp java-11-openjdk jetbrains-mono-fonts-all nmap podman-docker qemu virt-manager
            LocalPackages: code-1.89.1-1715060595.el8.x86_64 eddie-ui-2.21.8-0.x86_64 gdx-texturepacker-4.13.0-1.noarch
                Initramfs: regenerate

  ostree-image-signed:docker://ghcr.io/ublue-os/bazzite-nvidia:stable (index: 1)
                   Digest: sha256:2bd8d399e60fd24b3d8b3e3ac5dce742f2cc56d8f60d808428ed57454bf6a3c9
                  Version: 40.20240607.0 (2024-06-07T17:01:41Z)
               BaseCommit: 45bbbf34fc56ec2b295b370bbe8023de0d4870bc4dff7799f47f288261d1132e
                   Commit: ebe856355a781ca17651de0c46fbc3b8920ac9cc94effd708dc8e25cfa95e5ce
                StateRoot: default
          LayeredPackages: cascadia-fonts-all dotnet-sdk-6.0 edk2-ovmf freerdp java-11-openjdk jetbrains-mono-fonts-all nmap podman-docker qemu virt-manager
            LocalPackages: code-1.89.1-1715060595.el8.x86_64 eddie-ui-2.21.8-0.x86_64 gdx-texturepacker-4.13.0-1.noarch
                Initramfs: regenerate

Just occurred to me to test this. It seems to be X11 issue. The logout and restart via UI works when using Wayland.

So I guess we wait for nVidia driver update. I use Godot for development and it looks like the next version (4.3) will have Wayland support, then I can switch back to it. For now the terminal will have to do to reboot/shutdown.

1 Like

Same here, seems we’re all using X11 and Nvidia GPU’s…

Really wish Wayland worked better…

I think you’re right, I’ve really enjoyed my bazzite experience but the fact I have an nvidia card has caused a lot of problems.

Good thing I’m ready for an upgrade lmao

Hello,

The issue seems to be related to X11, so I downgraded "plasma-workspace-x11.x86_64" to 6.0.3-1.fc40.
And I have no issue at all now, beside the update notification for plasma updates
:slight_smile:

More info about the bug :
https://bugs.kde.org/show_bug.cgi?id=488187#c7

Edit :
Actually I just need to downgrade to 6.0.5

1 Like

Thank you for your response

How would I go about doing that? Is that rebasing?

I followed this Thread
And the answer by Kevin Kofler

1 Like

To clarify, the steps you took were

1: Download plasma-workspace-x11-6.0.5-1.fc40
from: plasma-workspace-x11-6.0.5-1.fc40 | Build Info | koji

2: Then enter “sudo dnf downgrade plasma-workspace plasma-workspace-x11”

1 Like