How to resolve undocumented errors from instalation?

Hello. I just switched from Fedora Workstation to Bazzite and I’m having some trouble with a series of errors that I have no idea how to fix. I’ll first explain what I’ve already done and then what problems I’m having. Maybe somebody has already experienced these and can help me?

First I used fedora media writer to flash Silverblue to a flash drive, then i installed it and went through the first steps. After that was done, I rebased to “bazzite-gnome-framework” and followed the Bazzite portal first steps. the portal remained installed after it finished, for some reason, but i left it in case it was important. Then, I ran “fleek --init” and “fleek apply”, because I wanted to experiment with nix stuff this time around.

Unfortunately, this is where I started encountering errors. all fleek commands I run to nothing and give an exit code 1. things that interact with fleek cause errors too. “just update” gives a vague error and tells me to look at the logs for more details, but there are no logs that mention mention fleek or nix anywhere.

There are also several other errors in the log app that I can’t find an explanation for. such as:

  • Failed to start bazzite-flatpak-manager.service - Manage system flatpaks.
  • Cannot change to /var/spool/at: No such file or directory
  • src/device.c:set_wake_allowed_complete() Set device flags return status: Invalid Parameters
  • ACPI BIOS Error (bug): Could not resolve symbol [_TZ.ETMD], AE_NOT_FOUND (20230628/psargs-330)
  • “/root” already exists and is not a directory.
  • /usr/lib/tmpfiles.d/systemd.conf:30: Failed to resolve group ‘systemd-journal’: No such process
  • /usr/lib/udev/rules.d/50-udev-default.rules:116 Unknown group ‘kvm’, ignoring.

these are just the ones I thought might be worth including, since the log is quite full right now.

Flatpak apps seem to be working fine, so I can still continue using my laptop for now, but the error message that pops up every time it tries to update is rather frustrating, since I have absolutely no idea how to fix it. I’ve never used nix or fleek before, and my experience with immutable distros is very limited. I’d appreciate any help you can offer.

I found some more information! not very much, but a bit anyway. So it turns out it’s not fleek that’s the issue, it’s Nix that’s causing problems. Any Nix command I try ends up not working as expected. Even simple ones. I’ve tried using the just commands to uninstall and reinstall Nix, but it still doesn’t work. I’ve even tried just manually installing Nix using the instructions on the Nix website, and i got an installation failure message.

So that’s that. Fleek isn’t the issue. I just don’t know how to progress from here, since nothing I try seems to get it working. Shame too, Nix would have made it so much easier to install network applications, since those can’t be used inside Distrobox without tons of work.