Dead in the water with black screen after login: 40 dead, can't go back to 39

When I first installed Bazzite 39, it ran fine under Wayland. Until one day, it didn’t. I switched to X11 and then everything was fine, until I updated to Bazzite 40. Then, I reinstalled X11 and things were ok for a few days until the next scheduled upgrade. And then nothing worked – X11 or Wayland.

I have tried to rebase to Aurora, which didn’t help. I have tried to rebase to 39, but a GPG error prevents me from doing so.

So: nothing at all works. Help!

sudo rpm-ostree rebase ostree-image-signed:docker://                  1 (04:53.252) < 12:34:47
Pulling manifest: ostree-image-signed:docker://
Importing: ostree-image-signed:docker:// (digest: sha256:e21ce65d04081a660df446a6bf57274e4926c8a41d2892414e8708e436cdb3ff)
ostree chunk layers already present: 33
ostree chunk layers needed: 32 (1.6 GB)
custom layers needed: 2 (1.0 GB)
Checking out tree 835b5be... done
Inactive requests:
  plasma-workspace-x11 (already provided by plasma-workspace-x11-5.27.11-1.fc39.x86_64)
Enabled rpm-md repositories: fedora-cisco-openh264 updates fedora rpmfusion-free-updates-testing rpmfusion-free-updates rpmfusion-free rpmfusion-nonfree-updates-testing rpmfusion-nonfree-updates rpmfusion-nonfree google-chrome updates-archive
Updating metadata for ''... done
Updating metadata for 'updates'... done
Updating metadata for 'rpmfusion-free-updates-testing'... done
error: Updating rpm-md repo 'rpmfusion-free-updates-testing': Failed to download gpg key for repo 'rpmfusion-free-updates-testing': Curl error (37): Couldn't read a file:// file for file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora-39 [Couldn't open file /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora-39]

I haven’t tested this but this is from chat:

cd /etc/pki/rpm-gpg
sudo ln -s RPM-GPG-KEY-rpmfusion-nonfree-fedora-2020 RPM-GPG-KEY-rpmfusion-nonfree-fedora-39

Yes, I tried this. But it doesn’t work. I get the same GPG error after running this command.

error: Updating rpm-md repo 'rpmfusion-free-updates-testing': Failed to download gpg key for repo 'rpmfusion-free-updates-testing': Curl error (37): Couldn't read a file:// file for file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora-39 [Couldn't open file /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora-39]

So I don’t have the technical chops (in linux) to be able to help as I just migrated over myself. I may, however, have a system config that might help diagnose this problem if someone more capable on the ublue team wanted to walk me through some things.

Long story short: I have this exact problem on bazzite starting about a week ago. Boot to SDDM, login, black screen. I can ctl+alt+F2 to get to another login terminal and login, but even things there will hang for ages. Here’s the fun part though: I’m running a dual boot with Aurora 40 on a separate drive (which is where I’m typing from) and not having the same issue at all over there so this is cleanly localized to Bazzite. I was also running Aurora and Bazzite during the beta 40 period and this is a relatively recent development in bazzite.

Also, in my very brief digging through logfiles I didn’t quite understand I saw an immense amount of complaining re: my MFG Crosswind rudder pedals by bazzite, specifically that it was trying to request a context prior to the user being initiated (or something like that, I don’t quite recall from when I looked it a week ago), for what it’s worth. I haven’t tried unplugging and rebooting, mostly because it’s all squirreled away in a closet (don’t ask) and actually accessing the cabling is moderately difficult so I haven’t bothered, though that’s likely my next step…

My system, for reference:

User @breathless19 provided a hack – get rid of GPG checks – but it worked. I can now access Aurora 39 through X11. Aurora 40 doesn’t work on X11 or Wayland, and 39 doesn’t work on Wayland. All give me the black screen.

Hey all,

Check my tutorial for how I fixed this on Aurora and see if it is relevant.

Fixing Blank/Black Screen After Login When Changing Login Shell to Fish

Hi! Thank you for finding this! I do indeed run the Fish shell so I was excited to try your fix… but I think it blew up my install. See this post for more details.

Not your fault, but I think the suggestion to do ujust configure-shell /bin/bash is not correct, it should probably be ujust configure-shell bash.