Boot iso from grub

Hello, I want to try bazzite, but I don’t have a media with 10G free space. I’m a linux user though and I already have grub configured. So I’m trying to boot the iso from grub using 40_custom file. I already managed to boot some other isos in the past, but I cannot find any specific info for bazzite. Also I recently upgraded to an UEFI system, so I don’t have any experience with iso boot in uefi mode.
I have found some info for other distros and I already tried some but don’t work. I have the iso in a gpt disk in ext4 partition. My last attempt is using archlinux’s iso boot as base from a relative thread I found. This is the entry I use:

menuentry "bazzite linux" --class fedora {
        insmod part_gpt
        insmod gzio
        insmod ext2
        search --no-floppy --set=root --fs-uuid $imguuid
        set isofile="/useful1/bazzite-deck-stable.iso"
        loopback loop "$isofile"
        linux /images/pxeboot/vmlinuz root=UUID=$imguuid img_loop=$isofile
        initrd /images/pxeboot/initrd.img

I have set the imguuid variable with the partition’s uuid.
This fails to boot with error: /images/pxeboot/vmlinuz not found
I found what’s wrong. I needed to add “(loop)” in front of the paths for linux and initrd.
Now the iso booted, but It dropped me to emergency shell with a Warning:/dev/root does not exist.
This happens after the Timeout waiting for device dev-gpt\x2dauto\x2droot.device - /dev/gpt-auto-root.
And some failed systemd dependences for check the root device, mount it, and initrd also.

After I tried a lot of different options, I never succeed to boot the iso. I get a little further, but again stuck at a start job of dev-mapper/live(or something, I don’t remember) which wanted 50mins max to stop.
So, I found a usb with enough space and tried to install from it, but seems impossible to install it. I tried many times and the installation fails with an error: “failed-to-write-boot-loader-configuration” which leads to installation fail after I press the continue button.
Also tried with the fedora silverblue iso, so to rebase to bazzite, but I get the same error there too, which seems that is a bug from fedora 30 which, from what I found in fedora’s forum, solved on fedora 32, but seems that is back on this version(and also 37 I think).
So, I’m about to give up and asking for some options. For example to bypass the bootloader installation(which I think was an option in the past), and install it later from archlinux which curently use via chroot.