Upgrade does not like mamba

If you are using mambaforge instead of stock conda, the upgrade tool will fail at the conda update step:

mamba failed: 
   0: Command failed: `mamba config --show auto_activate_base`

      Stdout:
      Currently, only install, create, list, search, run, info, clean, remove, update, repoquery, activate and deactivate are supported through mamba.
   1: `mamba` failed: exit status: 1

Is there any way of customizing this? Did not see anything in topgrade.toml.

how did you install mamba?

There wasn’t a brew for it so I used the installer distributed by the project.

That doesn’t tell us much. You have to be more precise. Otherwise it is a fool’s errand to reproduce the problem.

It was just running the shell script that is the installer:

bash Miniforge3-Linux-x86_64.sh

I had the same issue and I was able to prevent it by editing my /etc/ublue-os/topgrade.toml file to add the following:

[misc]
disable = ["conda", "mamba"]

I didn’t want topgrade to handle conda updates either, so I included both.

That sounds like what I need, but there does not seem to be a /etc/ublue-os/ on my system. There is a /etc/ublue-update/ with topgrade-system.toml and topgrade-user.toml, but adding the above disable command does not prevent update from trying to mess with conda/mamba.

Strange… I’m on Bazzite, not Bluefin or Aurora, but I figured topgrade would be fairly conserved across ublue variants.

Do you have /usr/share/ublue-os/topgrade.toml? Mine includes the following lines at the top:

[include]
paths = ["/etc/ublue-os/topgrade.toml"]

Which is what led me to the /etc config file. Maybe there’s something similar on your system that can lead you to the user-configurable file.

No [include] section in mine, thought there is a [misc] section with a ignore_failures entry.

Hm, sorry, this might be beyond my capacity as just a ublue user. It seems like these are relevant though, so maybe they could be bumped:

1 Like