Incus and Podman containers not starting at boot or login

Incus

Any ideas why Incus containers don’t seem to start at system startup or user login even when configured to do so?

I’ve used Incus in other distros and I’ve set containers to autostart using boot.autostart=true and they boot automatically as expected. However, in Bluefin this isn’t the case.

All I have to do is an incus list or seemingly any incus command and the containers configured for autostart will start up as expected.

Is there something I’m missing that would allow Incus containers to start automatically?

Podman

I’ve searched for this and found that in some scenarios Podman containers don’t start when the system starts (regardless of the distro) due to their daemonless nature. According to some docs the best way to do this is via systemd.

Is there a preferred solution to this with Bluefin?

I’ve done more research into the Incus issue. It looks like the daemon doesn’t start by default but there is an incus-startup service script that is used to auto start the daemon.

It’s included in the Bluefin-dx Incus install. I enabled the service but it throws an error when trying to start:

Jun 17 12:48:27 bluefin incusd[4420]: time="2024-06-17T12:48:27-05:00" level=warning msg="Instance type not operational" driver=qemu err="QEMU command not available: exec: \"qemu-system-x86_64\": executable file not found in $PATH" type=virtual-machine
Jun 17 12:48:27 bluefin incusd[4420]: Error: Failed to begin transaction: disk I/O error: permission denied

I tried adding myself to the libvirt group (based on another thread here) using the ujust dx-group command but it didn’t seem to fix the issue.

The qemu-system-x86_64 command is available to my user so I’m not sure why the service is throwing that error.

Has this been tested by anyone and is there a step I’m missing to get it to start at system boot?