How to configure automatic updates

Warning: Disabling automatic updates is an unsupported configuration.

Commands

The following just commands enable and disable the appropriate services:

  • ujust toggle-updates

Manually (Main images)

You can individually disable which automatic update timers ublue-os/config provides with the following commands:

  • flatpak system: sudo systemctl disable flatpak-system-update.timer
  • flatpak user: sudo systemctl --global disable flatpak-user-update.timer

You can also configure automatic rpm-ostree updates by editing /etc/rpm-ostreed.conf and changing “AutomaticUpdatePolicy” to “none” or “check”:

[Daemon]
AutomaticUpdatePolicy=check

Manually for Bazzite and Bluefin/Aurora

Bazzite and Bluefin use ublue-update, which you can enable and disable with the following commands:

  • systemctl disable ublue-update.timer - Disable automatic updates
  • systemctl enable ublue-update.timer - Enable automatic updates

Note that this timer handles the following components:

  • Flatpaks
  • Brew packages
  • Containers used by distrobox
  • VS Code extensions

and a variety of other components depending on what you install. Manual configuration of can be configured via /usr/share/ublue-os/topgrade.toml.

Check the topgrade for more features and options.

1 Like

I tried first command and got this:

❯ just enable-updates
error: Justfile does not contain recipe `enable-updates`.

I tried with ujust also, the same
What I am doing wrong ?

I forgot to update this doc when the change landed, it’s ujust toggle-updates.

Here’s the file if you wanna see what it’s doing:

1 Like

For automatic updates, are users prompted to confirm any changes to a flatpak’s permissions?