One Password installation

Has anyone been able to install 1Password properly? I’ve followed the flatpak instructions on the 1P website, but this results in an error when using the software app:

While pulling appstream2/x86_64 from remote onepassword-origin: Commit 41b518b73784cb24b15b464a2ea507a0d1c54bca42ce58a6c95864413674f7ef: GPG verification enabled, but no signatures found (use gpg-verify=false in remote config to disable)

Also, the flatpak version of 1P is fairly hobbled, with no working cli version and no SSH agent support.

I installed it from the rpm repository as an overlay. Has worked fine for years for me now.

Ooh, can you do that? When I tried the rpm route I got this (I assumed because Bluefin has locked all that down):

error: can’t create transaction lock on /usr/share/rpm/.rpm.lock (Read-only file system)
error: https://downloads.1password.com/linux/keys/1password.asc: key 1 import failed.

You can’t just use dnf as with Fedora Workstation. But once you’ve set up the repo details manually, you can use rpm-ostree as usual.

You can find my notes in the Monospace Mentor Wiki.

2 Likes

Would this (install as an overlay) apply to KeepassXC as well? The flatpak version doesn’t support browser integration, which is a real buzzkill.

I installed 1Password using the official .rpm file installed in a Fedora distrobox (BoxBuddy is preinstalled).

1 Like

I previously had it layered by manually adding the 1password repo like what the above solution has mentioned. However, I soon ran into a problem upgrading my system because of some error with the repo.

So I opted to installing the .rpm file directly instead, rpm-ostree install 1password-latest.rpm

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.