How can I add gamepad UI as session option on desktop Bazzite?

I’ve been a pretty happy user of the Bazzite Deck GNOME image for a while now, but I use desktop mode often enough that I’ve been thinking of switching to Bazzite GNOME instead. (Using a desktop image would also allow me to use LUKS encryption, which I would prefer to have on a semi-portable device like my PC.)

But I’d like if I could still have game mode as an option, in the login screen’s session picker or something. Is there any way I could do this?


I compared the packages on my Bazzite GNOME laptop with what comes installed on the Deck GNOME image, and so tried installing gamescope-session-plus, gamescope-session-opengamepadui, and gamescope-session-steam on the laptop. (This was a couple days ago but I think I had to edit /etc/yum.repos.d/_copr_kylegospo-bazzite.repo to set enabled=1)

Seemed like that ought to provide the executable and Wayland session .desktop file to let me log into the Steam gamepad UI, but it doesn’t appear in the list of session types when I click the gear icon on the GDM login screen…

…Actually it does appear as a session option, just not until after reboot :sweat_smile: duh

However, trying to log in after selecting either Steam Big Picture or OpenGamepadUI fails, redirecting me back to the user selection screen in GDM. I don’t see any errors in systemd journal for gdm.service after those failed login attempts, and I’m not sure else to look, though. :confused: