Community Guide: Setting up devpod with podman

Hoping these posts serve as a useful spot for newcomers and the community to help fill up to support the devs and an easy spot to curate and merge into the documentation.

Bluefin defaults to podman which is an excellent sensible default - podman - (rootless, best practice). However, little documentation or sharing of how to get started. I don’t know how to setup devpod to make use of podman. Help around that would be appreciated.

  1. Under settings, add CLI to path button doesn’t work. Steps to perform this ?
  2. Under providers, what to pick and fill in to make use of podman

There doesn’t appear to be a podman provider, just a docker one:

At the bottom of that page it appears it looks like adding providers to it should be straightforward. I suspect figuring out how to lie to devpod to make it think it’s talking to docker might also work?

Devpod works with docker seamlessly.

Step 1:
just docker

Step 2:
Connect devpod to docker

I was just curious if people were using it with podman.

One issue I’m having on bluefin however is that the ‘add to CLI’ button in devpod doesn’t work.

I’ve been using this machine for mainly data science , but since we are on break I’ve been working on trying to make it my daily driver as a simple non-developer user and just learn. I would attach a screenshot , but that’s another aspect I’m researching right now. When I install flameshot via flathub and try and take a screenshot , I just get an error saying unable to capture screen. Will have this resolve hopefully today and post instructions.

1 Like

So I somewhat figured this out .

under Docker Host put: unix:///var/run/user/1000/podman/podman.sock
under Docker path put: podman

Great thread @zartarr88
yes! same problem with flameshot! did you solve it?

Is this a viable solution? what do you mean by somewhat? :slightly_smiling_face:

It was working a couple months ago , after a couple updates it stopped but they introduced a ujust docker command . and I’ve just defaulted to docker for devpod.

1 Like

Hi there, are you still having issues with Flatpak Flameshot? If yes this might help:

  1. Install Flameshot from Flathub
  2. Give Flameshot screenshot permissions: flatpak permission-set screenshot screenshot org.flameshot.Flameshot yes
  3. Bind shortcut via Settings: flatpak run --command=flameshot -u org.flameshot.Flameshot gui
1 Like

hi @mel226, thanks for checking in!

After having installed flameshot from flathub and run the first line: flatpak permission-set screenshot screenshot org.flameshot.Flameshot yes

when I run the second line flatpak run --command=flameshot -u org.flameshot.Flameshot gui

I’m getting this error:
error: app/org.flameshot.Flameshot/x86_64/stable not installed

Try removing -u in the command - my Flameshot install is on user level and not like Bluefin’s default system level Flatpak, completely forgot about that! If after this Flameshot runs, you can bind the command via Gnome Settings to a certain key combo, e.g. Super+Shift+S

ok great,
what should I have for the command?

flatpak run --command=flameshot org.flameshot.Flameshot gui

Thanks a lot @mel226 ! It’s working perfectly now, pretty sweet!
I love Flameshot
have a good one