# \[Solved\] Can't run containers after rebasing

**URL:** <https://universal-blue.discourse.group/t/solved-cant-run-containers-after-rebasing/848>\
**Category:** General\
**Created:** [March 21, 2024, 1:55pm UTC](https://universal-blue.discourse.group/t/solved-cant-run-containers-after-rebasing/848 "2024-03-21T13:55:33Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![joegrammer](https://yyz2.discourse-cdn.com/free1/user_avatar/universal-blue.discourse.group/joegrammer/32/969_2.png) [@joegrammer](https://universal-blue.discourse.group/u/joegrammer)\
**Post date:** [March 21, 2024, 1:55pm UTC](https://universal-blue.discourse.group/t/solved-cant-run-containers-after-rebasing/848/1 "2024-03-21T13:55:33Z")

</div>

I was on the ublue kinoite spin and recently rebased on a wayblue one (hyprland). While on the former spin I used podman for almost everything I did. Now that I’ve rebased on the wayblue image I cannot attach to containers via podman. I can download images, and the containers I run actually start (I can see them with `podman ps -a` after they exit). Trying to run the container however fails. Here’s an example of what I’m seeing:

```auto
joe@oryp7-personal ~> podman ps -a
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
joe@oryp7-personal ~> podman run -ti hello-world
Resolved "hello-world" as an alias (/etc/containers/registries.conf.d/000-shortnames.conf)
Trying to pull quay.io/podman/hello:latest...
Getting image source signatures
Copying blob 83d537244900 done | 
Copying config a4e07799a3 done | 
Writing manifest to image destination
Error: OCI runtime error: crun: sd-bus call: Process org.freedesktop.systemd1 exited with status 1: Input/output error
joe@oryp7-personal ~ [126]> podman ps -a
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
421cb2d7062b quay.io/podman/hello:latest /usr/local/bin/po... 6 seconds ago Created exciting_zhukovsky
joe@oryp7-personal ~> podman run --detach hello-world
Error: OCI runtime error: crun: sd-bus call: Process org.freedesktop.systemd1 exited with status 1: Input/output error
joe@oryp7-personal ~ [126]> podman run hello-world # No arguments
Error: OCI runtime error: crun: sd-bus call: Process org.freedesktop.systemd1 exited with status 1: Input/output error
joe@oryp7-personal ~ [126]> 

```

Does anyone have an idea of what this error means or how to fix it?

EDIT: Seems to be dbus related. If I switch to a TTY and run `podman run hello-world` it works fine. But if I do `dbus-run-session podman run hello-world` it fails like above.

Thanks!

---

<div class="post-metadata">

**Author:** ![joegrammer](https://yyz2.discourse-cdn.com/free1/user_avatar/universal-blue.discourse.group/joegrammer/32/969_2.png) [@joegrammer](https://universal-blue.discourse.group/u/joegrammer)\
**Post date:** [March 21, 2024, 3:14pm UTC](https://universal-blue.discourse.group/t/solved-cant-run-containers-after-rebasing/848/2 "2024-03-21T15:14:48Z")

</div>

I solved issue. tl;dr don’t use `dbus-run-session` to start your wm.

Turns out that starting my window manager with `dbus-run-session` was the problem. These images (assuming all ublue images?) use dbus-broker instead of dbus-daemon as the dbus server implementation. dbus-broker does not have an equivalent to `dbus-run-session`, therefore running that command spins up a separate message bus that the window manager connects to. However, podman (maybe the cgroup? I don’t understand containers well enough at that level) is connecting to the original dbus-broker session. Removing `dbus-run-session` from the wm incantation fixed it.
